Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Patches » RHBA-2011:1447-01

Overview

Id RHBA-2011:1447-01
Name Red Hat 2011:1447-01 RHBA postgresql bug fix update for RHEL 5 x86
Vendor Name red_hat
Product None
Content Type Recommended Recommended
Language(s)
Operating System(s) Linux 
Released On 14 Nov 2011 12:00:00

RHBA-2011:1447-01

Red Hat 2011:1447-01 RHBA postgresql bug fix update for RHEL 5 x86

Vendor Name

red_hat

Product

None

Released On

14 Nov 2011 12:00:00

Url

https://rhn.redhat.com/errata/RHBA-2011-1447.html

Description

LSAC(v2)
PostgreSQL is an advanced Object-Relational database management system (DBMS). The base postgresql package includes client programs and libraries that are needed to access a PostgreSQL DBMS server. This update fixes the following bug: * The client library for PostgreSQL, libpq, sets up OpenSSL callback functions when using an SSL-encrypted connection to the database server. These callbacks were not unregistered when the connection to the database was closed. If the calling application unloaded the libpq library after closing the connection, any subsequent attempt to use OpenSSL failed with a segmentation fault. To fix this problem, OpenSSL callbacks are now unregistered whenever the last active database connection is closed so that the library can be unloaded safely. OpenSSL Segmentation faults no longer occur in the scenario described. (BZ#728828) All users of postgresql are advised to upgrade to these updated packages, which fix this bug.

Related Resources

Related Vulnerabilities

None

Related Patches

Superseded Patches

None


Last Updated: 27 May 2016 11:10:24