Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Patches » RHBA-2012:1113-01

Overview

Id RHBA-2012:1113-01
Name Red Hat 2012:1113-01 RHBA mod_python bug fix update for RHEL 5 x86
Vendor Name red_hat
Product None
Content Type Recommended Recommended
Language(s)
Operating System(s) Linux 
Released On 07 Jan 2013 12:00:00

RHBA-2012:1113-01

Red Hat 2012:1113-01 RHBA mod_python bug fix update for RHEL 5 x86

Vendor Name

red_hat

Product

None

Released On

07 Jan 2013 12:00:00

Url

https://rhn.redhat.com/errata/RHBA-2012-1113.html

Description

LSAC(v2)
The mod_python packages provide a module to embed the Python language interpreter within the Apache web server, allowing handlers to be written in Python. This update fixes the following bug: * Prior to this update, the publisher module did not correctly handle certain authentication variables. As a consequence, the web server could return an "400 Bad Request" error if the "publisher" handler was used with an authentication scheme other than "Basic". This update modifies the publisher.py code to handle the autentication as expected. (BZ#431684) All users of mod_python are advised to upgrade to these updated packages, which fix this bug.

Related Resources

Related Vulnerabilities

None

Related Patches

None

Superseded Patches

None


Last Updated: 27 May 2016 11:16:11