Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Patches » RHSA-2014:0311-01

Overview

Id RHSA-2014:0311-01
Name Red Hat 2014:0311-01 RHSA Critical: php security update for RHEL 5 x86
Vendor Name red_hat
Product None
Content Type Critical Critical
Language(s)
Operating System(s) Linux 
Released On 18 Mar 2014 12:00:00

RHSA-2014:0311-01

Red Hat 2014:0311-01 RHSA Critical: php security update for RHEL 5 x86

Vendor Name

red_hat

Product

None

Released On

18 Mar 2014 12:00:00

Url

https://rhn.redhat.com/errata/RHSA-2014-0311.html

Description

LSAC(v2)
PHP is an HTML-embedded scripting language commonly used with the Apache HTTP Server. A buffer overflow flaw was found in the way PHP parsed floating point numbers from their text representation. If a PHP application converted untrusted input strings to numbers, an attacker able to provide such input could cause the application to crash or, possibly, execute arbitrary code with the privileges of the application. (CVE-2009-0689) It was found that PHP did not properly handle file names with a NULL character. A remote attacker could possibly use this flaw to make a PHP script access unexpected files and bypass intended file system access restrictions. (CVE-2006-7243) All php users are advised to upgrade to these updated packages, which contain backported patches to correct these issues. After installing the updated packages, the httpd daemon must be restarted for the update to take effect.

Related Resources

Related Vulnerabilities

None

Related Patches

Superseded Patches


Last Updated: 27 May 2016 11:18:42