Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Patches » RHSA-2014:0474-01

Overview

Id RHSA-2014:0474-01
Name Red Hat 2014:0474-01 RHSA Important: struts security update for RHEL 5 x86
Vendor Name red_hat
Product None
Content Type Critical - 01 Critical - 01
Language(s)
Operating System(s) Linux 
Released On 07 May 2014 12:00:00

RHSA-2014:0474-01

Red Hat 2014:0474-01 RHSA Important: struts security update for RHEL 5 x86

Vendor Name

red_hat

Product

None

Released On

07 May 2014 12:00:00

Url

https://rhn.redhat.com/errata/RHSA-2014-0474.html

Description

LSAC(v2)
Apache Struts is a framework for building web applications with Java. It was found that the Struts 1 ActionForm object allowed access to the 'class' parameter, which is directly mapped to the getClass() method. A remote attacker could use this flaw to manipulate the ClassLoader used by an application server running Struts 1. This could lead to remote code execution under certain conditions. (CVE-2014-0114) All struts users are advised to upgrade to these updated packages, which contain a backported patch to correct this issue. All running applications using struts must be restarted for this update to take effect.

Related Resources

Related Vulnerabilities

None

Related Patches

Superseded Patches

None


Last Updated: 27 May 2016 11:18:48