Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2001-0170

Overview

Vulnerability Score 2.1 2.1
CVE Id CVE-2001-0170
Last Modified 05 Sep 2008 04:23:26
Published 26 Mar 2001 12:00:00
Confidentiality Impact PARTIAL PARTIAL
Integrity Impact NONE NONE
Availability Impact NONE NONE
Access Vector LOCAL
Access Complexity LOW
Authentication NONE

CVE-2001-0170

Summary

glibc 2.1.9x and earlier does not properly clear the RESOLV_HOST_CONF, HOSTALIASES, or RES_OPTIONS environmental variables when executing setuid/setgid programs, which could allow local users to read arbitrary files.

Vulnerable Systems

Operating System

  • Conectiva Linux 4.0

  • Conectiva Linux 4.0es

  • Conectiva Linux 4.1

  • Conectiva Linux 4.2

  • Conectiva Linux 5.0

  • Conectiva Linux 5.1

  • Conectiva Linux 6.0

  • Conectiva Linux Ecommerce

  • Conectiva Linux Graficas

  • Debian Linux 2.3

  • Redhat Linux 7.0

Application

  • Immunix 7.0 Beta


References

BID - 2181

REDHAT - RHSA-2001:001

BUGTRAQ - 20010110 [slackware-security] glibc 2.2 local vulnerability on setuid binaries

XF - linux-glibc-read-files

BUGTRAQ - 20010110 Glibc Local Root Exploit


Last Updated: 27 May 2016 10:36:10