Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2001-0191

Overview

Vulnerability Score 10.0 10.0
CVE Id CVE-2001-0191
Last Modified 05 Sep 2008 04:23:30
Published 03 May 2001 12:00:00
Confidentiality Impact COMPLETE COMPLETE
Integrity Impact COMPLETE COMPLETE
Availability Impact COMPLETE COMPLETE
Access Vector NETWORK
Access Complexity LOW
Authentication NONE

CVE-2001-0191

Summary

gnuserv before 3.12, as shipped with XEmacs, does not properly check the specified length of an X Windows MIT-MAGIC-COOKIE cookie, which allows remote attackers to execute arbitrary commands via a buffer overflow, or brute force authentication by using a short cookie length.

Vulnerable Systems

Application

  • Andy Norman Gnuserv 3.11


References

REDHAT - RHSA-2001:011

REDHAT - RHSA-2001:010

MANDRAKE - MDKSA-2001:019

BUGTRAQ - 20010202 Remote vulnerability in gnuserv/XEmacs

XF - gnuserv-tcp-cookie-overflow(6056)


Last Updated: 27 May 2016 10:36:10