Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2001-0317

Overview

Vulnerability Score 3.7 3.7
CVE Id CVE-2001-0317
Last Modified 10 Sep 2008 03:07:44
Published 03 May 2001 12:00:00
Confidentiality Impact PARTIAL PARTIAL
Integrity Impact PARTIAL PARTIAL
Availability Impact PARTIAL PARTIAL
Access Vector LOCAL
Access Complexity HIGH
Authentication NONE

CVE-2001-0317

Summary

Race condition in ptrace in Linux kernel 2.4 and 2.2 allows local users to gain privileges by using ptrace to track and modify a running setuid process.

Vulnerable Systems

Operating System

  • Linux Kernel 2.2.0

  • Linux Kernel 2.4.0


References

CALDERA - CSSA-2001-009

BUGTRAQ - 20010213 Trustix Security Advisory - proftpd, kernel

XF - linux-ptrace-modify-process(6080)

REDHAT - RHSA-2001:013


Last Updated: 27 May 2016 10:36:13