Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2001-1228

Overview

Vulnerability Score 7.5 7.5
CVE Id CVE-2001-1228
Last Modified 10 Sep 2008 03:09:58
Published 18 Nov 2001 12:00:00
Confidentiality Impact PARTIAL PARTIAL
Integrity Impact PARTIAL PARTIAL
Availability Impact PARTIAL PARTIAL
Access Vector NETWORK
Access Complexity LOW
Authentication NONE

CVE-2001-1228

Summary

Buffer overflows in gzip 1.3x, 1.2.4, and other versions might allow attackers to execute code via a long file name, possibly remotely if gzip is run on an FTP server.

Vulnerable Systems

Application

  • Gnu Gzip 1.2.4

  • Gnu Gzip 1.2.4a

  • Gnu Gzip 1.3


References

BUGTRAQ - 20011230 gzip bug w/ patch..

XF - gzip-long-filename-bo(7882)

NETBSD - NetBSD-SA2002-002

BID - 3712


Last Updated: 27 May 2016 10:36:35