Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2002-0043

Overview

Vulnerability Score 7.2 7.2
CVE Id CVE-2002-0043
Last Modified 10 Sep 2008 03:11:09
Published 31 Jan 2002 12:00:00
Confidentiality Impact COMPLETE COMPLETE
Integrity Impact COMPLETE COMPLETE
Availability Impact COMPLETE COMPLETE
Access Vector LOCAL
Access Complexity LOW
Authentication NONE

CVE-2002-0043

Summary

sudo 1.6.0 through 1.6.3p7 does not properly clear the environment before calling the mail program, which could allow local users to gain root privileges by modifying environment variables and changing how the mail program is invoked.

Vulnerable Systems

Application

  • Todd Miller Sudo 1.6

  • Todd Miller Sudo 1.6.1

  • Todd Miller Sudo 1.6.2

  • Todd Miller Sudo 1.6.3

  • Todd Miller Sudo 1.6.3 P1

  • Todd Miller Sudo 1.6.3 P2

  • Todd Miller Sudo 1.6.3 P3

  • Todd Miller Sudo 1.6.3 P4

  • Todd Miller Sudo 1.6.3 P5

  • Todd Miller Sudo 1.6.3 P6

  • Todd Miller Sudo 1.6.3 P7


References

REDHAT - RHSA-2002:013

MISC - http://www.sudo.ws/sudo/alerts/postfix.html

BUGTRAQ - 20020114 Sudo version 1.6.4 now available (fwd)

XF - sudo-unclean-env-root(7891)

BID - 3871

IMMUNIX - IMNX-2002-70-001-01

REDHAT - RHSA-2002:011

SUSE - SuSE-SA:2002:002

DEBIAN - DSA-101

BUGTRAQ - 20020116 Sudo +Postfix Exploit

MANDRAKE - MDKSA-2002:003

CONECTIVA - CLA-2002:451

FREEBSD - FreeBSD-SA-02:06


Last Updated: 27 May 2016 10:36:45