Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2002-0638

Overview

Vulnerability Score 6.2 6.2
CVE Id CVE-2002-0638
Last Modified 10 Sep 2008 03:12:37
Published 12 Aug 2002 12:00:00
Confidentiality Impact COMPLETE COMPLETE
Integrity Impact COMPLETE COMPLETE
Availability Impact COMPLETE COMPLETE
Access Vector LOCAL
Access Complexity HIGH
Authentication NONE

CVE-2002-0638

Summary

setpwnam.c in the util-linux package, as included in Red Hat Linux 7.3 and earlier, and other operating systems, does not properly lock a temporary file when modifying /etc/passwd, which may allow local users to gain privileges via a complex race condition that uses an open file descriptor in utility programs such as chfn and chsh.

Vulnerable Systems

Operating System

  • Hp Secure Os 1.0

  • Mandrakesoft Mandrake Linux 7.0

  • Mandrakesoft Mandrake Linux 7.1

  • Mandrakesoft Mandrake Linux 7.2

  • Mandrakesoft Mandrake Linux 8.0

  • Mandrakesoft Mandrake Linux 8.1

  • Mandrakesoft Mandrake Linux 8.2

  • Mandrakesoft Mandrake Linux Corporate Server 1.0.1

  • Redhat Linux 6.0

  • Redhat Linux 6.1

  • Redhat Linux 6.2

  • Redhat Linux 7.0

  • Redhat Linux 7.1

  • Redhat Linux 7.2

  • Redhat Linux 7.3

Application

  • Mandrakesoft Mandrake Single Network Firewall 7.2


References

CERT-VN - VU#405955

REDHAT - RHSA-2002:132

BID - 5344

REDHAT - RHSA-2002:137

OSVDB - 5164

MANDRAKE - MDKSA-2002:047

XF - utillinux-chfn-race-condition(9709)

HP - HPSBTL0207-054

BUGTRAQ - 20020729 RAZOR advisory: Linux util-linux chfn local root vulnerability

CONECTIVA - CLA-2002:523

BUGTRAQ - 20020730 TSLSA-2002-0064 - util-linux

VULNWATCH - 20020729 [VulnWatch] RAZOR advisory: Linux util-linux chfn local root vulnerability

CALDERA - CSSA-2002-043.0


Last Updated: 27 May 2016 10:37:00