Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2002-2253

Overview

Vulnerability Score 10.0 10.0
CVE Id CVE-2002-2253
Last Modified 05 Sep 2008 04:32:44
Published 31 Dec 2002 12:00:00
Confidentiality Impact COMPLETE COMPLETE
Integrity Impact COMPLETE COMPLETE
Availability Impact COMPLETE COMPLETE
Access Vector NETWORK
Access Complexity LOW
Authentication NONE

CVE-2002-2253

Summary

Multiple buffer overflows in Cyrus Sieve / libSieve 2.1.2 and earlier allow remote attackers to execute arbitrary code via (1) a long header name, (2) a long IMAP flag, or (3) a script that generates a large number of errors that overflow the resulting error string.

Vulnerable Systems

Application

  • Cyrus Libsieve 2.1.2


References

XF - cyrus-sieve-script-bo(10780)

XF - cyrus-sieve-imap-bo(10779)

XF - cyrus-sieve-header-bo(10743)

BID - 6300

BID - 6299

BID - 6294

BUGTRAQ - 20021202 Cyrus Sieve / libSieve buffer overflow


Last Updated: 27 May 2016 10:37:40