Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2002-2257

Overview

Vulnerability Score 10.0 10.0
CVE Id CVE-2002-2257
Last Modified 05 Sep 2008 04:32:44
Published 31 Dec 2002 12:00:00
Confidentiality Impact COMPLETE COMPLETE
Integrity Impact COMPLETE COMPLETE
Availability Impact COMPLETE COMPLETE
Access Vector NETWORK
Access Complexity LOW
Authentication NONE

CVE-2002-2257

Summary

Stack-based buffer overflow in the parse_field function in cgi_lib.c for LIBCGI 1.0.2 and 1.0.3 allows remote attackers to execute arbitrary code via a long argument.

Vulnerable Systems

Application

  • Tuxbr Libcgi 1.0.2

  • Tuxbr Libcgi 1.0.3


References

XF - libcgi-cgilibc-parsefield-bo(10722)

BID - 6270

BUGTRAQ - 20021128 Remote Multiple Buffer Overflow(s) vulnerability in Libcgi-tuxbr.


Last Updated: 27 May 2016 10:37:40