Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2002-1399

Overview

Vulnerability Score 10.0 10.0
CVE Id CVE-2002-1399
Last Modified 05 Sep 2008 04:30:29
Published 17 Jan 2003 12:00:00
Confidentiality Impact COMPLETE COMPLETE
Integrity Impact COMPLETE COMPLETE
Availability Impact COMPLETE COMPLETE
Access Vector NETWORK
Access Complexity LOW
Authentication NONE

CVE-2002-1399

Summary

Unknown vulnerability in cash_out and possibly other functions in PostgreSQL 7.2.1 and earlier, and possibly later versions before 7.2.3, with unknown impact, based on an invalid integer input which is processed as a different data type, as demonstrated using cash_out(2).

Vulnerable Systems

Application

  • Postgresql 6.3.2

  • Postgresql 6.5.3

  • Postgresql 7.0.3

  • Postgresql 7.1

  • Postgresql 7.1.1

  • Postgresql 7.1.2

  • Postgresql 7.1.3

  • Postgresql 7.2

  • Postgresql 7.2.1


References

MISC - http://archives.postgresql.org/pgsql-hackers/2002-08/msg00713.php

MISC - http://archives.postgresql.org/pgsql-hackers/2002-08/msg00708.php

BUGTRAQ - 20020819 Re: @(#) Mordred Labs advisory 0x0001: Buffer overflow in PostgreSQL


Last Updated: 27 May 2016 10:37:19