Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2002-1400

Overview

Vulnerability Score 7.5 7.5
CVE Id CVE-2002-1400
Last Modified 10 Sep 2008 03:14:31
Published 17 Jan 2003 12:00:00
Confidentiality Impact PARTIAL PARTIAL
Integrity Impact PARTIAL PARTIAL
Availability Impact PARTIAL PARTIAL
Access Vector NETWORK
Access Complexity LOW
Authentication NONE

CVE-2002-1400

Summary

Heap-based buffer overflow in the repeat() function for PostgreSQL before 7.2.2 allows attackers to execute arbitrary code by causing repeat() to generate a large string.

Vulnerable Systems

Application

  • Postgresql 6.3.2

  • Postgresql 6.5.3

  • Postgresql 7.0.3

  • Postgresql 7.1

  • Postgresql 7.1.1

  • Postgresql 7.1.2

  • Postgresql 7.1.3

  • Postgresql 7.2

  • Postgresql 7.2.1


References

SUSE - SuSE-SA:2002:038

BUGTRAQ - 20020820 @(#)Mordred Labs advisory 0x0003: Buffer overflow in PostgreSQL

CONFIRM - http://archives.postgresql.org/pgsql-announce/2002-08/msg00004.php

REDHAT - RHSA-2003:001

MANDRAKE - MDKSA-2002:062

SECUNIA - 8034

CONFIRM - http://marc.theaimsgroup.com/?l=postgresql-announce&m=103062536330644

BUGTRAQ - 20020826 GLSA: PostgreSQL

BUGTRAQ - 20020824 Fwd: [GENERAL] PostgreSQL 7.2.2: Security Release

CONECTIVA - CLA-2002:524


Last Updated: 27 May 2016 10:37:19