Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2002-1490

Overview

Vulnerability Score 2.1 2.1
CVE Id CVE-2002-1490
Last Modified 05 Sep 2008 04:30:44
Published 02 Apr 2003 12:00:00
Confidentiality Impact NONE NONE
Integrity Impact NONE NONE
Availability Impact PARTIAL PARTIAL
Access Vector LOCAL
Access Complexity LOW
Authentication NONE

CVE-2002-1490

Summary

NetBSD 1.4 through 1.6 beta allows local users to cause a denial of service (kernel panic) via a series of calls to the TIOCSCTTY ioctl, which causes an integer overflow in a structure counter and sets the counter to zero, which frees memory that is still in use by other processes.

Vulnerable Systems

Operating System

  • Netbsd 1.4

  • Netbsd 1.4.1

  • Netbsd 1.4.2

  • Netbsd 1.4.3

  • Netbsd 1.5

  • Netbsd 1.5.1

  • Netbsd 1.5.2

  • Netbsd 1.5.3

  • Netbsd 1.6


References

BID - 5722

XF - netbsd-tiocsctty-ioctl-bo(10115)

OSVDB - 7566

NETBSD - NetBSD-SA2002-007


Last Updated: 27 May 2016 10:37:22