Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2003-0107

Overview

Vulnerability Score 7.5 7.5
CVE Id CVE-2003-0107
Last Modified 10 Sep 2008 08:05:50
Published 07 Mar 2003 12:00:00
Confidentiality Impact PARTIAL PARTIAL
Integrity Impact PARTIAL PARTIAL
Availability Impact PARTIAL PARTIAL
Access Vector NETWORK
Access Complexity LOW
Authentication NONE

CVE-2003-0107

Summary

Buffer overflow in the gzprintf function in zlib 1.1.4, when zlib is compiled without vsnprintf or when long inputs are truncated using vsnprintf, allows attackers to cause a denial of service or possibly execute arbitrary code.

Vulnerable Systems

Application

  • Gnu Zlib 1.1.4


References

CERT-VN - VU#142121

XF - zlib-gzprintf-bo(11381)

BUGTRAQ - 20030222 buffer overrun in zlib 1.1.4

BUGTRAQ - 20030223 poc zlib sploit just for fun :)

CONFIRM - http://lists.apple.com/mhonarc/security-announce/msg00038.html

BID - 6913

REDHAT - RHSA-2003:081

REDHAT - RHSA-2003:079

OSVDB - 6599

MANDRAKE - MDKSA-2003:033

SUNALERT - 57405

GENTOO - GLSA-200303-25

BUGTRAQ - 20030225 [sorcerer-spells] ZLIB-SORCERER2003-02-25

BUGTRAQ - 20030224 Re: buffer overrun in zlib 1.1.4

CONECTIVA - CLSA-2003:619

NETBSD - NetBSD-SA2003-004

CALDERA - CSSA-2003-011.0


Last Updated: 27 May 2016 10:37:47