Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2003-0163

Overview

Vulnerability Score 5.0 5.0
CVE Id CVE-2003-0163
Last Modified 05 Sep 2008 04:33:39
Published 05 May 2003 12:00:00
Confidentiality Impact NONE NONE
Integrity Impact NONE NONE
Availability Impact PARTIAL PARTIAL
Access Vector NETWORK
Access Complexity LOW
Authentication NONE

CVE-2003-0163

Summary

decrypt_msg for the Gaim-Encryption GAIM plugin 1.15 and earlier does not properly validate a message length parameter, which allows remote attackers to cause a denial of service (crash) via a negative length, which overwrites arbitrary heap memory with a zero byte.

Vulnerable Systems

Application

  • Gaim-encryption 1.13

  • Gaim-encryption 1.14

  • Gaim-encryption 1.15


References

BID - 7182

MISC - http://www.rapid7.com/advisories/R7-0013.html

BUGTRAQ - 20030412 R7-0013: Heap Corruption in Gaim-Encryption Plugin


Last Updated: 27 May 2016 10:37:48