Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2004-0435

Overview

Vulnerability Score 3.6 3.6
CVE Id CVE-2004-0435
Last Modified 10 Sep 2008 03:26:23
Published 18 Aug 2004 12:00:00
Confidentiality Impact NONE NONE
Integrity Impact PARTIAL PARTIAL
Availability Impact PARTIAL PARTIAL
Access Vector LOCAL
Access Complexity LOW
Authentication NONE

CVE-2004-0435

Summary

Certain "programming errors" in the msync system call for FreeBSD 5.2.1 and earlier, and 4.10 and earlier, do not properly handle the MS_INVALIDATE operation, which leads to cache consistency problems that allow a local user to prevent certain changes to files from being committed to disk.

Vulnerable Systems

Operating System

  • Freebsd 4.0

  • Freebsd 4.10

  • Freebsd 4.8

  • Freebsd 4.9

  • Freebsd 5.2

  • Freebsd 5.2.1


References

FREEBSD - FreeBSD-SA-04:11

XF - freebsd-msync-gain-privileges(16254)

BID - 10416

SECUNIA - 11714


Last Updated: 27 May 2016 10:38:36