Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2004-0590

Overview

Vulnerability Score 10.0 10.0
CVE Id CVE-2004-0590
Last Modified 05 Sep 2008 04:38:50
Published 06 Dec 2004 12:00:00
Confidentiality Impact COMPLETE COMPLETE
Integrity Impact COMPLETE COMPLETE
Availability Impact COMPLETE COMPLETE
Access Vector NETWORK
Access Complexity LOW
Authentication NONE

CVE-2004-0590

Summary

FreeS/WAN 1.x and 2.x, and other related products including superfreeswan 1.x, openswan 1.x before 1.0.6, openswan 2.x before 2.1.4, and strongSwan before 2.1.3, allows remote attackers to authenticate using spoofed PKCS#7 certificates in which a self-signed certificate identifies an alternate Certificate Authority (CA) and spoofed issuer and subject.

Vulnerable Systems

Application

  • Frees Wan 1

  • Frees Wan 2

  • Openswan 1

  • Openswan 2

  • Strongswan 2.1.2

  • Super Frees Wan 1


References

XF - ipsec-verifyx509cert-auth-bypass(16515)

CONFIRM - http://www.openswan.org/support/vuln/can-2004-0590/

MANDRAKE - MDKSA-2004:070

GENTOO - GLSA-200406-20


Last Updated: 27 May 2016 10:38:40