Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2004-0751

Overview

Vulnerability Score 5.0 5.0
CVE Id CVE-2004-0751
Last Modified 21 Aug 2010 12:21:12
Published 20 Oct 2004 12:00:00
Confidentiality Impact NONE NONE
Integrity Impact NONE NONE
Availability Impact PARTIAL PARTIAL
Access Vector NETWORK
Access Complexity LOW
Authentication NONE

CVE-2004-0751

Summary

The char_buffer_read function in the mod_ssl module for Apache 2.x, when using reverse proxying to an SSL server, allows remote attackers to cause a denial of service (segmentation fault).

Vulnerable Systems

Application

  • Apache Http Server 2.0

  • Apache Http Server 2.0.28

  • Apache Http Server 2.0.32

  • Apache Http Server 2.0.35

  • Apache Http Server 2.0.36

  • Apache Http Server 2.0.37

  • Apache Http Server 2.0.38

  • Apache Http Server 2.0.39

  • Apache Http Server 2.0.40

  • Apache Http Server 2.0.41

  • Apache Http Server 2.0.42

  • Apache Http Server 2.0.43

  • Apache Http Server 2.0.44

  • Apache Http Server 2.0.45

  • Apache Http Server 2.0.46

  • Apache Http Server 2.0.47

  • Apache Http Server 2.0.48

  • Apache Http Server 2.0.49

  • Apache Http Server 2.0.50


References

XF - apache-modssl-speculative-dos(17273)

REDHAT - RHSA-2004:463

TRUSTIX - 2004-0047

SUSE - SUSE-SA:2004:030

MANDRAKE - MDKSA-2004:096

GENTOO - GLSA-200409-21

CONFIRM - http://issues.apache.org/bugzilla/show_bug.cgi?id=30134

BUGTRAQ - 20040911 Remote buffer overflow in Apache mod_ssl when reverse proxying SSL


Last Updated: 27 May 2016 10:38:44