Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2004-0755

Overview

Vulnerability Score 2.1 2.1
CVE Id CVE-2004-0755
Last Modified 21 Aug 2010 12:21:12
Published 20 Oct 2004 12:00:00
Confidentiality Impact PARTIAL PARTIAL
Integrity Impact NONE NONE
Availability Impact NONE NONE
Access Vector LOCAL
Access Complexity LOW
Authentication NONE

CVE-2004-0755

Summary

The FileStore capability in CGI::Session for Ruby before 1.8.1, and possibly PStore, creates files with insecure permissions, which can allow local users to steal session information and hijack sessions.

Vulnerable Systems

Application

  • Yukihiro Matsumoto Ruby 1.6

  • Yukihiro Matsumoto Ruby 1.8


References

XF - ruby-filestore-pstore-insecure-permission(16996)

GENTOO - GLSA-200409-08

DEBIAN - DSA-537

SECUNIA - 12290

MANDRAKE - MDKSA-2004:128


Last Updated: 27 May 2016 10:38:44