Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2004-0870

Overview

Vulnerability Score 5.0 5.0
CVE Id CVE-2004-0870
Last Modified 05 Sep 2008 04:39:37
Published 16 Sep 2004 12:00:00
Confidentiality Impact PARTIAL PARTIAL
Integrity Impact NONE NONE
Availability Impact NONE NONE
Access Vector NETWORK
Access Complexity LOW
Authentication NONE

CVE-2004-0870

Summary

KDE Konqueror does not prevent cookies that are sent over an insecure channel (HTTP) from also being sent over a secure channel (HTTPS/SSL) in the same domain, which could allow remote attackers to steal cookies and conduct unauthorized activities, aka "Cross Security Boundary Cookie Injection."

Vulnerable Systems

Application

  • Kde Konqueror 2.1.1

  • Kde Konqueror 2.1.2

  • Kde Konqueror 2.2.1

  • Kde Konqueror 2.2.2

  • Kde Konqueror 3.0

  • Kde Konqueror 3.0.1

  • Kde Konqueror 3.0.2

  • Kde Konqueror 3.0.3

  • Kde Konqueror 3.0.5

  • Kde Konqueror 3.0.5b

  • Kde Konqueror 3.1

  • Kde Konqueror 3.1.1

  • Kde Konqueror 3.1.2

  • Kde Konqueror 3.1.3

  • Kde Konqueror 3.1.4

  • Kde Konqueror 3.1.5

  • Kde Konqueror 3.2.1

  • Kde Konqueror 3.2.3


References

MISC - http://www.westpoint.ltd.uk/advisories/wp-04-0001.txt

BUGTRAQ - 20040916 wp-04-0001: Multiple Browser Cookie Injection Vulnerabilities

XF - web-browser-cookie-session-hijack(17417)

SECTRACK - 1011330


Last Updated: 27 May 2016 10:38:47