Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2004-1405

Overview

Vulnerability Score 7.5 7.5
CVE Id CVE-2004-1405
Last Modified 05 Sep 2008 04:41:16
Published 31 Dec 2004 12:00:00
Confidentiality Impact PARTIAL PARTIAL
Integrity Impact PARTIAL PARTIAL
Availability Impact PARTIAL PARTIAL
Access Vector NETWORK
Access Complexity LOW
Authentication NONE

CVE-2004-1405

Summary

MediaWiki 1.3.8 and earlier, when used with Apache mod_mime, does not properly handle files with two file extensions, such as .php.rar, which allows remote attackers to upload and execute arbitrary code.

Vulnerable Systems

Application

  • Mediawiki 1.3

  • Mediawiki 1.3.0

  • Mediawiki 1.3.1

  • Mediawiki 1.3.10

  • Mediawiki 1.3.11

  • Mediawiki 1.3.2

  • Mediawiki 1.3.3

  • Mediawiki 1.3.4

  • Mediawiki 1.3.5

  • Mediawiki 1.3.6

  • Mediawiki 1.3.7

  • Mediawiki 1.3.8


References

BID - 11985

MISC - http://wikipedia.sourceforge.net/

BUGTRAQ - 20041216 STG Security Advisory: [SSA-20041215-19] Vulnerability of uploading files with multiple extensions in MediaWiki

SECUNIA - 13478


Last Updated: 27 May 2016 10:39:01