Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2004-1701

Overview

Vulnerability Score 10.0 10.0
CVE Id CVE-2004-1701
Last Modified 05 Sep 2008 04:42:06
Published 09 Aug 2004 12:00:00
Confidentiality Impact COMPLETE COMPLETE
Integrity Impact COMPLETE COMPLETE
Availability Impact COMPLETE COMPLETE
Access Vector NETWORK
Access Complexity LOW
Authentication NONE

CVE-2004-1701

Summary

Heap-based buffer overflow in the AuthenticationDialogue function in cfservd for Cfengine 2.0.0 to 2.1.7p1 allows remote attackers to execute arbitrary code via a long SAUTH command during RSA authentication.

Vulnerable Systems

Application

  • Gnu Cfengine 2.0.0

  • Gnu Cfengine 2.0.1

  • Gnu Cfengine 2.0.2

  • Gnu Cfengine 2.0.3

  • Gnu Cfengine 2.0.4

  • Gnu Cfengine 2.0.5

  • Gnu Cfengine 2.0.6

  • Gnu Cfengine 2.0.7

  • Gnu Cfengine 2.0.8

  • Gnu Cfengine 2.1.0

  • Gnu Cfengine 2.1.7


References

XF - cfengine-cfservd-command-execution(16935)

BID - 10899

MISC - http://www.coresecurity.com/common/showdoc.php?idx=387&idxseccion=10

GENTOO - GLSA-200408-08

SECUNIA - 12251

BUGTRAQ - 20050219 cfengine rsa heap remote exploit: part of PTjob project

BUGTRAQ - 20040809 CORE-2004-0714: Cfengine RSA Authentication Heap Corruption


Last Updated: 27 May 2016 10:39:09