Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2004-1837

Overview

Vulnerability Score 4.3 4.3
CVE Id CVE-2004-1837
Last Modified 05 Sep 2008 04:42:29
Published 31 Dec 2004 12:00:00
Confidentiality Impact NONE NONE
Integrity Impact PARTIAL PARTIAL
Availability Impact NONE NONE
Access Vector NETWORK
Access Complexity MEDIUM
Authentication NONE

CVE-2004-1837

Summary

Cross-site scripting (XSS) vulnerability in Mod_survey 3.0.x before 3.0.16-pre2 and 3.2.x before 3.2.0-pre4 allows remote attackers to inject arbitrary web script or HTML via the certain survey fields or error messages for malformed query strings.

Vulnerable Systems

Application

  • Joel Palmius Mod Survey 3.0.0

  • Joel Palmius Mod Survey 3.0.1

  • Joel Palmius Mod Survey 3.0.10

  • Joel Palmius Mod Survey 3.0.11

  • Joel Palmius Mod Survey 3.0.12

  • Joel Palmius Mod Survey 3.0.13

  • Joel Palmius Mod Survey 3.0.14

  • Joel Palmius Mod Survey 3.0.14d

  • Joel Palmius Mod Survey 3.0.14e

  • Joel Palmius Mod Survey 3.0.15

  • Joel Palmius Mod Survey 3.0.15 Pre1

  • Joel Palmius Mod Survey 3.0.15 Pre2

  • Joel Palmius Mod Survey 3.0.15 Pre3

  • Joel Palmius Mod Survey 3.0.15 Pre4

  • Joel Palmius Mod Survey 3.0.15 Pre5

  • Joel Palmius Mod Survey 3.0.15 Pre6

  • Joel Palmius Mod Survey 3.0.16 Pre1

  • Joel Palmius Mod Survey 3.0.2

  • Joel Palmius Mod Survey 3.0.3

  • Joel Palmius Mod Survey 3.0.4

  • Joel Palmius Mod Survey 3.0.5

  • Joel Palmius Mod Survey 3.0.6

  • Joel Palmius Mod Survey 3.0.9

  • Joel Palmius Mod Survey 3.2.0 Pre1

  • Joel Palmius Mod Survey 3.2.0 Pre2

  • Joel Palmius Mod Survey 3.2.0 Pre3


References

BID - 9941

SECTRACK - 1009516

XF - modsurvey-xss(15582)

BUGTRAQ - 20040322 Mod_Survey security advisory: Script injection bug


Last Updated: 27 May 2016 10:39:12