Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2004-1946

Overview

Vulnerability Score 4.6 4.6
CVE Id CVE-2004-1946
Last Modified 05 Sep 2008 04:42:46
Published 19 Apr 2004 12:00:00
Confidentiality Impact PARTIAL PARTIAL
Integrity Impact PARTIAL PARTIAL
Availability Impact PARTIAL PARTIAL
Access Vector LOCAL
Access Complexity LOW
Authentication NONE

CVE-2004-1946

Summary

Format string vulnerability in the PRINT_ERROR function in common.c for Cherokee Web Server 0.4.16 and earlier allows local users to execute arbitrary code via format string specifiers in the -C command line argument. NOTE: it is not clear whether this issue could be exploited remotely, or if Cherokee is running at escalated privileges. Therefore it might not be a vulnerability.

Vulnerable Systems

Application

  • Cherokee Httpd 0.4.16


References

XF - cherokee-printerror-format-string(15924)

MISC - http://www.nosystem.com.ar/advisories/advisory-03.txt

BUGTRAQ - 20040420 Format String in Cherokee


Last Updated: 27 May 2016 10:39:14