Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2004-2043

Overview

Vulnerability Score 5.0 5.0
CVE Id CVE-2004-2043
Last Modified 05 Sep 2008 04:43:02
Published 01 May 2004 12:00:00
Confidentiality Impact NONE NONE
Integrity Impact NONE NONE
Availability Impact PARTIAL PARTIAL
Access Vector NETWORK
Access Complexity LOW
Authentication NONE

CVE-2004-2043

Summary

Buffer overflow in ibserver for Firebird Database 1.0 and other versions before 1.5, and possibly other products that use the InterBase codebase, allows remote attackers to cause a denial of service (crash) via a long database name, as demonstrated using the gsec command.

Vulnerable Systems

Application

  • Borland Software Interbase 4.0

  • Borland Software Interbase 5.0

  • Borland Software Interbase 6.0

  • Borland Software Interbase 6.4

  • Borland Software Interbase 6.5

  • Borland Software Interbase 7.0

  • Borland Software Interbase 7.1

  • Borland Software Interbase Superserver 6.0

  • Firebirdsql Firebird 1.0


References

SECUNIA - 11756

XF - interbase-database-name-bo(16316)

XF - firebird-database-name-bo(16229)

BID - 10446

MISC - http://www.securiteam.com/unixfocus/5AP0P0UCUO.html

OSVDB - 6624

OSVDB - 6408

DEBIAN - DSA-1014

SECTRACK - 1010381

SECUNIA - 19350

BUGTRAQ - 20040601 Firebird Database Remote Database Name Overflow

FULLDISC - 20040602 Firebird [ AND Interbase 7 ] Database Remote Database Name Overflow


Last Updated: 27 May 2016 10:39:18