Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2004-2133

Overview

Vulnerability Score 4.6 4.6
CVE Id CVE-2004-2133
Last Modified 05 Sep 2008 04:43:17
Published 29 Jan 2004 12:00:00
Confidentiality Impact PARTIAL PARTIAL
Integrity Impact PARTIAL PARTIAL
Availability Impact PARTIAL PARTIAL
Access Vector LOCAL
Access Complexity LOW
Authentication NONE

CVE-2004-2133

Summary

Certain third-party packages for CVSup 16.1h, such as SuSE Linux, contain untrusted paths in the ELF RPATH fields of certain executables, which could allow local users to execute arbitrary code by causing cvsup to link against malicious libraries that are created in world-writable directories such as /usr/src/packages.

Vulnerable Systems

Application

  • Cvsup Cvsup-16.1h-2.i386.rpm

  • Cvsup Cvsup-16.1h-36.i586.rpm

  • Cvsup Cvsup-16.1h-43.i586.rpm


References

XF - cvsup-rpath-gain-privileges(14994)

BID - 9523

BUGTRAQ - 20040129 Security Announcement: untrusted ELF library path in some cvsup binary RPMs


Last Updated: 27 May 2016 10:39:21