Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2004-2171

Overview

Vulnerability Score 4.3 4.3
CVE Id CVE-2004-2171
Last Modified 05 Sep 2008 04:43:23
Published 31 Dec 2004 12:00:00
Confidentiality Impact NONE NONE
Integrity Impact PARTIAL PARTIAL
Availability Impact NONE NONE
Access Vector NETWORK
Access Complexity MEDIUM
Authentication NONE

CVE-2004-2171

Summary

Cross-site scripting (XSS) vulnerability in Cherokee before 0.4.8 allows remote attackers to inject arbitrary web script or HTML via the URL, which is not properly quoted in the resulting error page.

Vulnerable Systems

Application

  • Cherokee Httpd 0.1

  • Cherokee Httpd 0.1.5

  • Cherokee Httpd 0.1.6

  • Cherokee Httpd 0.2

  • Cherokee Httpd 0.2.5

  • Cherokee Httpd 0.2.6

  • Cherokee Httpd 0.2.7

  • Cherokee Httpd 0.4.6

  • Cherokee Httpd 0.4.7


References

BID - 9496

OSVDB - 3707

SECUNIA - 10701

XF - cherokee-error-xss(14936)


Last Updated: 27 May 2016 10:39:22