Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2004-2172

Overview

Vulnerability Score 5.0 5.0
CVE Id CVE-2004-2172
Last Modified 05 Sep 2008 04:43:23
Published 31 Dec 2004 12:00:00
Confidentiality Impact PARTIAL PARTIAL
Integrity Impact NONE NONE
Availability Impact NONE NONE
Access Vector NETWORK
Access Complexity LOW
Authentication NONE

CVE-2004-2172

Summary

EarlyImpact ProductCart uses a weak encryption scheme to encrypt passwords, which allows remote attackers to obtain the password via a chosen plaintext attack.

Vulnerable Systems

Application

  • Early Impact Productcart 1.5

  • Early Impact Productcart 1.5002

  • Early Impact Productcart 1.5003

  • Early Impact Productcart 1.5003r

  • Early Impact Productcart 1.5004

  • Early Impact Productcart 1.6 B

  • Early Impact Productcart 1.6 B001

  • Early Impact Productcart 1.6 B002

  • Early Impact Productcart 1.6 B003

  • Early Impact Productcart 1.6 Br

  • Early Impact Productcart 1.6 Br001

  • Early Impact Productcart 1.6 Br003

  • Early Impact Productcart 1.6002

  • Early Impact Productcart 1.6003

  • Early Impact Productcart 2.0

  • Early Impact Productcart 2.0 Br000

  • Early Impact Productcart 2.5


References

XF - productcart-keystream-obtain-information(15231)

BID - 9669

MISC - http://www.s-quadra.com/advisories/Adv-20040216.txt

BUGTRAQ - 20040218 Re: EarlyImpact ProductCart shopping cart software multiple security vulnerabilities

BUGTRAQ - 20040216 EarlyImpact ProductCart shopping cart software multiple security vulnerabilities

OSVDB - 3979

CONFIRM - http://www.earlyimpact.com/productcart/support/updates/ReadMe_ProductCart_Security_Patch_013004.txt

SECTRACK - 1009085

SECUNIA - 10898


Last Updated: 27 May 2016 10:39:22