Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2004-2484

Overview

Vulnerability Score 4.3 4.3
CVE Id CVE-2004-2484
Last Modified 05 Sep 2008 04:44:16
Published 31 Dec 2004 12:00:00
Confidentiality Impact NONE NONE
Integrity Impact PARTIAL PARTIAL
Availability Impact NONE NONE
Access Vector NETWORK
Access Complexity MEDIUM
Authentication NONE

CVE-2004-2484

Summary

Cross-site scripting (XSS) vulnerability in PHP Gift Registry 1.3.5 and earlier allows remote attackers to inject arbitrary web script or HTML via the message parameter to (1) event.php or (2) index.php.

Vulnerable Systems

Application

  • Php Gift Registry Phpgiftreg 1.0.2

  • Php Gift Registry Phpgiftreg 1.1.0

  • Php Gift Registry Phpgiftreg 1.2.0

  • Php Gift Registry Phpgiftreg 1.3.0

  • Php Gift Registry Phpgiftreg 1.3.1

  • Php Gift Registry Phpgiftreg 1.3.2

  • Php Gift Registry Phpgiftreg 1.3.3

  • Php Gift Registry Phpgiftreg 1.3.4

  • Php Gift Registry Phpgiftreg 1.3.5


References

XF - phpgiftregistry-message-xss(18412)

BID - 11879

OSVDB - 12287

OSVDB - 12286

CONFIRM - http://sourceforge.net/project/shownotes.php?release_id=288731

SECUNIA - 13414

CONFIRM - http://cvs.sourceforge.net/viewcvs.py/phpgiftreg/src/index.php?r1=1.20&r2=1.21

CONFIRM - http://cvs.sourceforge.net/viewcvs.py/phpgiftreg/src/event.php?r1=1.4&r2=1.5


Last Updated: 27 May 2016 10:39:29