Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2004-2490

Overview

Vulnerability Score 4.6 4.6
CVE Id CVE-2004-2490
Last Modified 07 Mar 2011 09:18:56
Published 31 Dec 2004 12:00:00
Confidentiality Impact PARTIAL PARTIAL
Integrity Impact PARTIAL PARTIAL
Availability Impact PARTIAL PARTIAL
Access Vector LOCAL
Access Complexity LOW
Authentication NONE

CVE-2004-2490

Summary

Buffer overflow in IBM Informix Dynamic Server (IDS) 9.40.xC1 and 9.40.xC2 allows local users to execute arbitrary code via a long GL_PATH environment variable.

Vulnerable Systems

Application

  • Ibm Informix Dynamic Server 9.40.uc1

  • Ibm Informix Dynamic Server 9.40.uc2

  • Ibm Informix Extended Parallel Server 8.40 Uc1

  • Ibm Informix Extended Parallel Server 8.40 Uc2


References

XF - informix-ids-glpath-bo(14949)

BID - 9511

OSVDB - 3756

MISC - http://www-1.ibm.com/support/docview.wss?uid=swg21153336

SECUNIA - 10737

BUGTRAQ - 20030314 SRT2004-01-18-0747 - IBM Informix IDS 9.4 contains multiple vulnerabilities


Last Updated: 27 May 2016 10:39:30