Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2004-2589

Overview

Vulnerability Score 5.0 5.0
CVE Id CVE-2004-2589
Last Modified 05 Sep 2008 04:44:34
Published 31 Dec 2004 12:00:00
Confidentiality Impact NONE NONE
Integrity Impact NONE NONE
Availability Impact PARTIAL PARTIAL
Access Vector NETWORK
Access Complexity LOW
Authentication NONE

CVE-2004-2589

Summary

Gaim before 0.82 allows remote servers to cause a denial of service (application crash) via a long HTTP Content-Length header, which causes Gaim to abort when attempting to allocate memory.

Vulnerable Systems

Application

  • Rob Flynn Gaim 0.10

  • Rob Flynn Gaim 0.10.3

  • Rob Flynn Gaim 0.50

  • Rob Flynn Gaim 0.51

  • Rob Flynn Gaim 0.52

  • Rob Flynn Gaim 0.53

  • Rob Flynn Gaim 0.54

  • Rob Flynn Gaim 0.55

  • Rob Flynn Gaim 0.56

  • Rob Flynn Gaim 0.57

  • Rob Flynn Gaim 0.58

  • Rob Flynn Gaim 0.59

  • Rob Flynn Gaim 0.59.1

  • Rob Flynn Gaim 0.60

  • Rob Flynn Gaim 0.61

  • Rob Flynn Gaim 0.62

  • Rob Flynn Gaim 0.63

  • Rob Flynn Gaim 0.64

  • Rob Flynn Gaim 0.65

  • Rob Flynn Gaim 0.66

  • Rob Flynn Gaim 0.67

  • Rob Flynn Gaim 0.68

  • Rob Flynn Gaim 0.69

  • Rob Flynn Gaim 0.70

  • Rob Flynn Gaim 0.71

  • Rob Flynn Gaim 0.72

  • Rob Flynn Gaim 0.73

  • Rob Flynn Gaim 0.74

  • Rob Flynn Gaim 0.75

  • Rob Flynn Gaim 0.76

  • Rob Flynn Gaim 0.77

  • Rob Flynn Gaim 0.78

  • Rob Flynn Gaim 0.79

  • Rob Flynn Gaim 0.80

  • Rob Flynn Gaim 0.81

  • Rob Flynn Gaim 0.82


References

BID - 11056

SECUNIA - 12383

XF - gaim-content-length-dos(17150)

OSVDB - 9264

SECTRACK - 1011083

CONFIRM - http://gaim.sourceforge.net/security/?id=6


Last Updated: 27 May 2016 10:39:32