Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2004-2592

Overview

Vulnerability Score 5.0 5.0
CVE Id CVE-2004-2592
Last Modified 05 Sep 2008 04:44:34
Published 31 Dec 2004 12:00:00
Confidentiality Impact NONE NONE
Integrity Impact NONE NONE
Availability Impact PARTIAL PARTIAL
Access Vector NETWORK
Access Complexity LOW
Authentication NONE

CVE-2004-2592

Summary

Quake II server before R1Q2, as used in multiple products, allows remote attackers cause a denial of service (application crash) via a modified client that asks the server to send data stored at a negative array offset, which is not handled when processing Configstrings and Baselines.

Vulnerable Systems

Application

  • Id Software Quake Ii Server 3.20

  • Id Software Quake Ii Server 3.21


References

XF - quake-configstrings-baselines-dos(17890)

BID - 11551

OSVDB - 11181

CONFIRM - http://web.archive.org/web/20041130092749/www.r1ch.net/stuff/r1q2/

SECTRACK - 1011979

MISC - http://secur1ty.net/advisories/001

SECUNIA - 13013

BUGTRAQ - 20041027 Multiple Vulnerabilites in Quake II Server


Last Updated: 27 May 2016 10:39:33