Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2004-2687

Overview

Vulnerability Score 9.3 9.3
CVE Id CVE-2004-2687
Last Modified 05 Sep 2008 12:00:00
Published 31 Dec 2004 12:00:00
Confidentiality Impact COMPLETE COMPLETE
Integrity Impact COMPLETE COMPLETE
Availability Impact COMPLETE COMPLETE
Access Vector NETWORK
Access Complexity MEDIUM
Authentication NONE

CVE-2004-2687

Summary

distcc 2.x, as used in XCode 1.5 and others, when not configured to restrict access to the server port, allows remote attackers to execute arbitrary commands via compilation jobs, which are executed by the server without authorization checks.

Vulnerable Systems

Application

  • Apple Xcode 1.5

  • Samba 2.18.3


References

OSVDB - 13378

MISC - http://www.metasploit.org/projects/Framework/exploits.html#distcc_exec

MLIST - [distcc] 20040826 Exploit in distcc ( got compromised ;( )

CONFIRM - http://distcc.samba.org/security.html

BUGTRAQ - 20050310 XCode 1.5 and distcc 2.x Exploit


Last Updated: 27 May 2016 10:39:34