Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2004-0940

Overview

Vulnerability Score 6.9 6.9
CVE Id CVE-2004-0940
Last Modified 07 Mar 2011 09:16:25
Published 09 Feb 2005 12:00:00
Confidentiality Impact COMPLETE COMPLETE
Integrity Impact COMPLETE COMPLETE
Availability Impact COMPLETE COMPLETE
Access Vector LOCAL
Access Complexity MEDIUM
Authentication NONE

CVE-2004-0940

Summary

Buffer overflow in the get_tag function in mod_include for Apache 1.3.x to 1.3.32 allows local users who can create SSI documents to execute arbitrary code as the apache user via SSI (XSSI) documents that trigger a length calculation error.

Vulnerable Systems

Operating System

  • Hp-ux 11.00

  • Hp-ux 11.11

  • Hp-ux 11.20

  • Hp-ux 11.22

  • Slackware Linux 10.0

  • Slackware Linux 8.0

  • Slackware Linux 8.1

  • Slackware Linux 9.0

  • Slackware Linux 9.1

  • Slackware Linux Current

  • Suse Linux 8.0

  • Suse Linux 8.1

  • Suse Linux 8.2

  • Suse Linux 9.0

  • Suse Linux 9.1

  • Suse Linux 9.2

  • Trustix Secure Linux 1.5

Application

  • Apache Http Server 1.3

  • Apache Http Server 1.3.1

  • Apache Http Server 1.3.11

  • Apache Http Server 1.3.12

  • Apache Http Server 1.3.14

  • Apache Http Server 1.3.17

  • Apache Http Server 1.3.18

  • Apache Http Server 1.3.19

  • Apache Http Server 1.3.20

  • Apache Http Server 1.3.22

  • Apache Http Server 1.3.23

  • Apache Http Server 1.3.24

  • Apache Http Server 1.3.25

  • Apache Http Server 1.3.26

  • Apache Http Server 1.3.27

  • Apache Http Server 1.3.28

  • Apache Http Server 1.3.29

  • Apache Http Server 1.3.3

  • Apache Http Server 1.3.31

  • Apache Http Server 1.3.32

  • Apache Http Server 1.3.4

  • Apache Http Server 1.3.6

  • Apache Http Server 1.3.7

  • Apache Http Server 1.3.9

  • Openpkg 2.0

  • Openpkg 2.1

  • Openpkg 2.2

  • Openpkg Current


References

BID - 11471

OPENPKG - OpenPKG-SA-2004.047

XF - apache-modinclude-bo(17785)

VUPEN - ADV-2006-0789

REDHAT - RHSA-2005:816

REDHAT - RHSA-2004:600

MANDRAKE - MDKSA-2004:134

DEBIAN - DSA-594

CONFIRM - http://www.apacheweek.com/features/security-13

CONFIRM - http://support.avaya.com/elmodocs2/security/ASA-2006-081.htm

SUNALERT - 102197

SECTRACK - 1011783

SECUNIA - 19073

SECUNIA - 12898


Last Updated: 27 May 2016 10:38:49