Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2004-0983

Overview

Vulnerability Score 5.0 5.0
CVE Id CVE-2004-0983
Last Modified 21 Aug 2010 12:21:35
Published 01 Mar 2005 12:00:00
Confidentiality Impact NONE NONE
Integrity Impact NONE NONE
Availability Impact PARTIAL PARTIAL
Access Vector NETWORK
Access Complexity LOW
Authentication NONE

CVE-2004-0983

Summary

The CGI module in Ruby 1.6 before 1.6.8, and 1.8 before 1.8.2, allows remote attackers to cause a denial of service (infinite loop and CPU consumption) via a certain HTTP request.

Vulnerable Systems

Operating System

  • Gentoo Linux

  • Mandrakesoft Mandrake Linux 10.0

  • Mandrakesoft Mandrake Linux 10.1

  • Mandrakesoft Mandrake Linux 9.2

  • Mandrakesoft Mandrake Linux Corporate Server 2.1

  • Ubuntu Linux 4.1

Application

  • Yukihiro Matsumoto Ruby 1.6

  • Yukihiro Matsumoto Ruby 1.6.7

  • Yukihiro Matsumoto Ruby 1.8

  • Yukihiro Matsumoto Ruby 1.8.1

  • Yukihiro Matsumoto Ruby 1.8.2 Pre1

  • Yukihiro Matsumoto Ruby 1.8.2 Pre2


References

BID - 11618

XF - ruby-cgi-dos(17985)

UBUNTU - USN-20-1

REDHAT - RHSA-2004:635

DEBIAN - DSA-586

MANDRAKE - MDKSA-2004:128


Last Updated: 27 May 2016 10:38:50