Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2004-1309

Overview

Vulnerability Score 10.0 10.0
CVE Id CVE-2004-1309
Last Modified 10 Sep 2008 03:29:47
Published 10 Jan 2005 12:00:00
Confidentiality Impact COMPLETE COMPLETE
Integrity Impact COMPLETE COMPLETE
Availability Impact COMPLETE COMPLETE
Access Vector NETWORK
Access Complexity LOW
Authentication NONE

CVE-2004-1309

Summary

Heap-based buffer overflow in the demux_open_bmp function in demux_bmp.c for Unix MPlayer 1.0pre5 allows remote attackers to execute arbitrary code via a bitmap (BMP) file containing a large biClrUsed field.

Vulnerable Systems

Application

  • Unix Mplayer 1.0 Pre5


References

XF - mplayer-bitmap-bo(18527)

CONFIRM - http://www1.mplayerhq.hu/MPlayer/releases/ChangeLog

IDEFENSE - 20041216 MPlayer Bitmap Parsing Remote Heap Overflow Vulnerability

MANDRAKE - MDKSA-2004:157


Last Updated: 27 May 2016 10:38:58