Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2005-0101

Overview

Vulnerability Score 7.5 7.5
CVE Id CVE-2005-0101
Last Modified 05 Sep 2008 04:45:19
Published 01 Feb 2005 12:00:00
Confidentiality Impact PARTIAL PARTIAL
Integrity Impact PARTIAL PARTIAL
Availability Impact PARTIAL PARTIAL
Access Vector NETWORK
Access Complexity LOW
Authentication NONE

CVE-2005-0101

Summary

Buffer overflow in the socket_getline function in Newspost 2.1.1 and earlier allows remote malicious NNTP servers to execute arbitrary code via a long string without a newline character.

Vulnerable Systems

Application

  • Newspost 2.1.1


References

GENTOO - GLSA-200502-05

XF - newspost-socketgetline-bo(19178)

CONFIRM - http://www.vuxml.org/freebsd/7f13607b-6948-11d9-8937-00065be4b5b6.html

SECUNIA - 14092

MISC - http://people.freebsd.org/~niels/issues/newspost-20050114.txt

BUGTRAQ - 20050202 RE: SECURITEY.NNOV.RU NewsPost buffer overflow [EXPLOIT]

BID - 12418

SECTRACK - 1013056

SECUNIA - 14098


Last Updated: 27 May 2016 10:39:40