Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2005-0174

Overview

Vulnerability Score 5.0 5.0
CVE Id CVE-2005-0174
Last Modified 21 Aug 2010 12:25:36
Published 07 Feb 2005 12:00:00
Confidentiality Impact NONE NONE
Integrity Impact PARTIAL PARTIAL
Availability Impact NONE NONE
Access Vector NETWORK
Access Complexity LOW
Authentication NONE

CVE-2005-0174

Summary

Squid 2.5 up to 2.5.STABLE7 allows remote attackers to poison the cache or conduct certain attacks via headers that do not follow the HTTP specification, including (1) multiple Content-Length headers, (2) carriage return (CR) characters that are not part of a CRLF pair, and (3) header names containing whitespace characters.

Vulnerable Systems

Application

  • Squid 2.5 .stable1

  • Squid 2.5 .stable3

  • Squid 2.5 .stable4

  • Squid 2.5 .stable5

  • Squid 2.5 .stable6

  • Squid 2.5 Stable3

  • Squid 2.5 Stable4

  • Squid 2.5 Stable9

  • Squid 2.5.6

  • Squid 2.5.stable1

  • Squid 2.5.stable2

  • Squid 2.5.stable3

  • Squid 2.5.stable4

  • Squid 2.5.stable5

  • Squid 2.5.stable6

  • Squid 2.5.stable7


References

CERT-VN - VU#768702

REDHAT - RHSA-2005:061

REDHAT - RHSA-2005:060

CONFIRM - http://www.squid-cache.org/Versions/v2/2.5/bugs/#squid-2.5.STABLE7-header_parsing

FEDORA - FEDORA-2005-373

SUSE - SUSE-SA:2005:006

BUGTRAQ - 20050207 [USN-77-1] Squid vulnerabilities

CONECTIVA - CLA-2005:931

BID - 12412

MANDRAKE - MDKSA-2005:034

FEDORA - FLSA-2006:152809


Last Updated: 27 May 2016 10:39:42