Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2005-0269

Overview

Vulnerability Score 7.5 7.5
CVE Id CVE-2005-0269
Last Modified 05 Sep 2008 04:45:48
Published 02 May 2005 12:00:00
Confidentiality Impact PARTIAL PARTIAL
Integrity Impact PARTIAL PARTIAL
Availability Impact PARTIAL PARTIAL
Access Vector NETWORK
Access Complexity LOW
Authentication NONE

CVE-2005-0269

Summary

The file extension check in GNUBoard 3.40 and earlier only verifies extensions that contain all lowercase letters, which allows remote attackers to upload arbitrary files via file extensions that include uppercase letters.

Vulnerable Systems

Application

  • Sir Gnuboard 3.30

  • Sir Gnuboard 3.31

  • Sir Gnuboard 3.32

  • Sir Gnuboard 3.33

  • Sir Gnuboard 3.34

  • Sir Gnuboard 3.35

  • Sir Gnuboard 3.36

  • Sir Gnuboard 3.37

  • Sir Gnuboard 3.38

  • Sir Gnuboard 3.39

  • Sir Gnuboard 3.40


References

XF - gnuboard-gbupdate-file-upload(18729)

BID - 12149

SECUNIA - 13711

BUGTRAQ - 20050103 STG Security Advisory: [SSA-20041224-21] File extensions


Last Updated: 27 May 2016 10:39:44