Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2005-2081

Overview

Vulnerability Score 5.0 5.0
CVE Id CVE-2005-2081
Last Modified 05 Sep 2008 04:50:50
Published 05 Jul 2005 12:00:00
Confidentiality Impact NONE NONE
Integrity Impact PARTIAL PARTIAL
Availability Impact NONE NONE
Access Vector NETWORK
Access Complexity LOW
Authentication NONE

CVE-2005-2081

Summary

Stack-based buffer overflow in the function that parses commands in Asterisk 1.0.7, when the 'write = command' option is enabled, allows remote attackers to execute arbitrary code via a command that has two double quotes followed by a tab character.

Vulnerable Systems

Application

  • Digium Asterisk 1.0.7


References

XF - asterisk-manager-interface-bo(21115)

MISC - http://www.portcullis-security.com/advisory/advisory-05-013.txt

BUGTRAQ - 20050622 Portcullis Security Advisory 05-013 - VoIP - Asterisk Stack Overflow


Last Updated: 27 May 2016 10:40:23