Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2005-3671

Overview

Vulnerability Score 7.8 7.8
CVE Id CVE-2005-3671
Last Modified 05 Sep 2008 04:54:59
Published 18 Nov 2005 04:03:00
Confidentiality Impact NONE NONE
Integrity Impact NONE NONE
Availability Impact COMPLETE COMPLETE
Access Vector NETWORK
Access Complexity LOW
Authentication NONE

CVE-2005-3671

Summary

The Internet Key Exchange version 1 (IKEv1) implementation in Openswan 2 (openswan-2) before 2.4.4, and freeswan in SUSE LINUX 9.1 before 2.04_1.5.4-1.23, allow remote attackers to cause a denial of service via (1) a crafted packet using 3DES with an invalid key length, or (2) unspecified inputs when Aggressive Mode is enabled and the PSK is known, as demonstrated by the PROTOS ISAKMP Test Suite for IKEv1.

Vulnerable Systems

Application

  • Frees Wan 2.04

  • Openswan 2.1.1

  • Openswan 2.1.2

  • Openswan 2.1.4

  • Openswan 2.1.5

  • Openswan 2.1.6

  • Openswan 2.2

  • Openswan 2.3

  • Openswan 2.4


References

CERT-VN - VU#226364

BID - 15416

CONFIRM - http://www.openswan.org/niscc2/

FEDORA - FEDORA-2005-1093

FEDORA - FEDORA-2005-1092

SUSE - SUSE-SA:2005:070

MISC - http://www.niscc.gov.uk/niscc/docs/re-20051114-01014.pdf?lang=en

GENTOO - GLSA-200512-04

MISC - http://www.ee.oulu.fi/research/ouspg/protos/testing/c09/isakmp/

SECTRACK - 1015214

SECUNIA - 18115

SECUNIA - 17980

SECUNIA - 17680

SECUNIA - 17581

MISC - http://jvn.jp/niscc/NISCC-273756/index.html

BUGTRAQ - 20051214 Re: [ GLSA 200512-04 ] Openswan, IPsec-Tools: Vulnerabilities in ISAK MP Protocol implementation

BUGTRAQ - 20051213 Re: [ GLSA 200512-04 ] Openswan, IPsec-Tools: Vulnerabilities in ISAK MP Protocol implementation


Last Updated: 27 May 2016 10:41:00