Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2005-3926

Overview

Vulnerability Score 7.5 7.5
CVE Id CVE-2005-3926
Last Modified 07 Mar 2011 09:27:23
Published 30 Nov 2005 06:03:00
Confidentiality Impact PARTIAL PARTIAL
Integrity Impact PARTIAL PARTIAL
Availability Impact PARTIAL PARTIAL
Access Vector NETWORK
Access Complexity LOW
Authentication NONE

CVE-2005-3926

Summary

Direct static code injection vulnerability in error.php in GuppY 4.5.9 and earlier, when register_globals is disabled, allows remote attackers to execute arbitrary PHP code via the _SERVER[REMOTE_ADDR] parameter, which is injected into a .inc script that is later included by the main script.

Vulnerable Systems

Application

  • Guppy 4.5

  • Guppy 4.5.3

  • Guppy 4.5.3a

  • Guppy 4.5.4

  • Guppy 4.5.9


References

VUPEN - ADV-2005-2635

BID - 15609

BUGTRAQ - 20051128 Guppy <= 4.5.9 Remote code execution

SECTRACK - 1015279

SECUNIA - 17790

MISC - http://rgod.altervista.org/guppy459_xpl.html

XF - guppy-error-file-include(23318)


Last Updated: 27 May 2016 10:41:06