Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2005-3964

Overview

Vulnerability Score 7.5 7.5
CVE Id CVE-2005-3964
Last Modified 07 Mar 2011 09:27:27
Published 02 Dec 2005 06:03:00
Confidentiality Impact PARTIAL PARTIAL
Integrity Impact PARTIAL PARTIAL
Availability Impact PARTIAL PARTIAL
Access Vector NETWORK
Access Complexity LOW
Authentication NONE

CVE-2005-3964

Summary

Multiple buffer overflows in libUil (libUil.so) in OpenMotif 2.2.3, and possibly other versions, allows attackers to execute arbitrary code via the (1) diag_issue_diagnostic function in UilDiags.c and (2) open_source_file function in UilSrcSrc.c.

Vulnerable Systems

Application

  • Integrated Computer Solutions Openmotif 2.2.3


References

VUPEN - ADV-2005-2709

FULLDISC - 20051201 [xfocus-SD-051202]openMotif-libUil-Multiple_vulnerability

XF - openmotif-opensourcefile-bo(23389)

XF - openmotif-diagissuediagnostic-bo(23388)

BID - 15686

BID - 15684

BUGTRAQ - 20051202 [xfocus-SD-051202]openMotif libUil Multiple vulnerability

REDHAT - RHSA-2008:0261

REDHAT - RHSA-2006:0272

SECTRACK - 1015303


Last Updated: 27 May 2016 10:41:08