Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2005-4463

Overview

Vulnerability Score 5.0 5.0
CVE Id CVE-2005-4463
Last Modified 05 Sep 2008 04:56:57
Published 21 Dec 2005 05:03:00
Confidentiality Impact PARTIAL PARTIAL
Integrity Impact NONE NONE
Availability Impact NONE NONE
Access Vector NETWORK
Access Complexity LOW
Authentication NONE

CVE-2005-4463

Summary

WordPress before 1.5.2 allows remote attackers to obtain sensitive information via a direct request to (1) wp-includes/vars.php, (2) wp-content/plugins/hello.php, (3) wp-admin/upgrade-functions.php, (4) wp-admin/edit-form.php, (5) wp-settings.php, and (6) wp-admin/edit-form-comment.php, which leaks the path in an error message related to undefined functions or failed includes. NOTE: the wp-admin/menu-header.php vector is already covered by CVE-2005-2110. NOTE: the vars.php, edit-form.php, wp-settings.php, and edit-form-comment.php vectors were also reported to affect WordPress 2.0.1.

Vulnerable Systems

Application

  • Wordpress 1.0

  • Wordpress 1.0.1

  • Wordpress 1.0.2

  • Wordpress 1.2

  • Wordpress 1.5

  • Wordpress 1.5.1

  • Wordpress 1.5.1.2

  • Wordpress 1.5.1.3

  • Wordpress 2.0.1


References

BUGTRAQ - 20060227 WordPress 2.0.1 Multiple Vulnerabilities

BUGTRAQ - 20051220 [ECHO_ADV_24$2005] Full path disclosure on WordPress < 1.5.2

BUGTRAQ - 20051221 [ECHO_ADV_24$2005] Full path disclosure on WordPress < 1.5.2

MISC - http://NeoSecurityTeam.net/advisories/Advisory-17.txt

MISC - http://echo.or.id/adv/adv24-theday-2005.txt

SREASON - 286


Last Updated: 27 May 2016 10:41:18