Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2005-4593

Overview

Vulnerability Score 7.5 7.5
CVE Id CVE-2005-4593
Last Modified 05 Sep 2008 04:57:16
Published 31 Dec 2005 12:00:00
Confidentiality Impact PARTIAL PARTIAL
Integrity Impact PARTIAL PARTIAL
Availability Impact PARTIAL PARTIAL
Access Vector NETWORK
Access Complexity LOW
Authentication NONE

CVE-2005-4593

Summary

PHP remote file inclusion vulnerability in phpDocumentor 1.3.0 rc4 and earlier, when register_globals is enabled, allows remote attackers to execute arbitrary code via a URL in the (1) FORUM[LIB] parameter in Documentation/tests/bug-559668.php and (2) the root_dir parameter in docbuilder/file_dialog.php.

Vulnerable Systems

Application

  • Joshua Eichorn Phpdocumentor 1.2

  • Joshua Eichorn Phpdocumentor 1.2.1

  • Joshua Eichorn Phpdocumentor 1.2.2

  • Joshua Eichorn Phpdocumentor 1.2.3

  • Joshua Eichorn Phpdocumentor 1.3 Rc3

  • Joshua Eichorn Phpdocumentor 1.3 Rc4


References

BID - 16080

BUGTRAQ - 20051229 PhpDocumentor <= 1.3.0 rc4 Arbitrary remote/local inclusion

MISC - http://rgod.altervista.org/phpdocumentor_130rc4_incl_expl.html

XF - phpdocumentor-multiple-script-file-include(23902)

OSVDB - 22115

OSVDB - 22114

SECTRACK - 1015423

SREASON - 303

SECUNIA - 18248


Last Updated: 27 May 2016 10:41:22