Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2006-0056

Overview

Vulnerability Score 7.5 7.5
CVE Id CVE-2006-0056
Last Modified 07 Mar 2011 09:29:14
Published 13 Feb 2006 06:06:00
Confidentiality Impact PARTIAL PARTIAL
Integrity Impact PARTIAL PARTIAL
Availability Impact PARTIAL PARTIAL
Access Vector NETWORK
Access Complexity LOW
Authentication NONE

CVE-2006-0056

Summary

Double free vulnerability in the authentication and authentication token alteration code in PAM-MySQL 0.6.x before 0.6.2 and 0.7.x before 0.7pre3 allows remote attackers to cause a denial of service (application crash) and possibly execute arbitrary code via crafted passwords, which lead to a double free of a pointer that was created by the pam_get_item function. NOTE: this issue only occurs in certain configurations in which there are multiple PAM modules, PAM-MySQL is not evaluated first, and there are no requisite modules before PAM-MySQL.

Vulnerable Systems

Application

  • Pam-mysql 0.1

  • Pam-mysql 0.2

  • Pam-mysql 0.3

  • Pam-mysql 0.4

  • Pam-mysql 0.4.7

  • Pam-mysql 0.5

  • Pam-mysql 0.6

  • Pam-mysql 0.7 Pre1

  • Pam-mysql 0.7 Pre2


References

CERT-VN - VU#693909

BID - 16564

SECTRACK - 1015603

SECUNIA - 18598

VUPEN - ADV-2006-0490

OSVDB - 22995

OSVDB - 22994

GENTOO - GLSA-200606-18

CONFIRM - http://sourceforge.net/forum/forum.php?forum_id=499394

SECUNIA - 20690

MISC - http://jvn.jp/cert/JVNVU%23693909/index.html


Last Updated: 27 May 2016 10:41:31