Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2006-0576

Overview

Vulnerability Score 7.2 7.2
CVE Id CVE-2006-0576
Last Modified 16 Jun 2011 12:00:00
Published 07 Feb 2006 07:06:00
Confidentiality Impact COMPLETE COMPLETE
Integrity Impact COMPLETE COMPLETE
Availability Impact COMPLETE COMPLETE
Access Vector LOCAL
Access Complexity LOW
Authentication NONE

CVE-2006-0576

Summary

Untrusted search path vulnerability in opcontrol in OProfile 0.9.1 and earlier allows local users to execute arbitrary commands via a modified PATH that references malicious (1) which or (2) dirname programs. NOTE: while opcontrol normally is not run setuid, a common configuration suggests accessing opcontrol using sudo. In such a context, this is a vulnerability.

Vulnerable Systems

Application

  • Maynard Johnson Oprofile 0.1

  • Maynard Johnson Oprofile 0.2

  • Maynard Johnson Oprofile 0.3

  • Maynard Johnson Oprofile 0.4

  • Maynard Johnson Oprofile 0.5

  • Maynard Johnson Oprofile 0.5.1

  • Maynard Johnson Oprofile 0.5.2

  • Maynard Johnson Oprofile 0.5.3

  • Maynard Johnson Oprofile 0.5.4

  • Maynard Johnson Oprofile 0.6

  • Maynard Johnson Oprofile 0.6.1

  • Maynard Johnson Oprofile 0.7

  • Maynard Johnson Oprofile 0.7.1

  • Maynard Johnson Oprofile 0.8

  • Maynard Johnson Oprofile 0.8.1

  • Maynard Johnson Oprofile 0.8.2

  • Maynard Johnson Oprofile 0.9

  • Maynard Johnson Oprofile 0.9.1


References

BID - 16536

BUGTRAQ - 20060207 Arbitrary code execution via OProfile

MISC - http://www.redhat.com/magazine/012oct05/features/oprofile/


Last Updated: 27 May 2016 10:41:42