Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2006-1087

Overview

Vulnerability Score 6.5 6.5
CVE Id CVE-2006-1087
Last Modified 07 Mar 2011 09:32:00
Published 08 Mar 2006 07:02:00
Confidentiality Impact PARTIAL PARTIAL
Integrity Impact PARTIAL PARTIAL
Availability Impact PARTIAL PARTIAL
Access Vector NETWORK
Access Complexity LOW
Authentication SINGLE_INSTANCE

CVE-2006-1087

Summary

Direct static code injection vulnerability in the modify_config action in admin.php for PHP-Stats 0.1.9.1 and earlier allows remote authenticated administrators to execute arbitrary PHP code via the option_new[compatibility_mode] parameter, which is not filtered before being stored in config.php. NOTE: this vulnerability can be exploited by remote unauthenticated attackers in conjunction with the option[admin_pass] authentication bypass vulnerability.

Vulnerable Systems

Application

  • Php-stats 0.1.9.1


References

VUPEN - ADV-2006-0822

BID - 16963

BUGTRAQ - 20060304 PHP-Stats <= 0.1.9.1 remote commands execution

MISC - http://www.phpstats.net/forum/viewtopic.php?t=140

SECUNIA - 19116

MISC - http://retrogod.altervista.org/php_stats_0191_adv.html

BUGTRAQ - 20060327 Re: PHP-Stats <= 0.1.9.1 remote commands execution

BUGTRAQ - 20060322 Re: PHP-Stats <= 0.1.9.1 remote commands execution


Last Updated: 27 May 2016 10:41:55